Call Support: +1 (647) 557 5884

What operating systems are compatible with Able2Extract 8?

Follow

You can install and run Able2Extract 8 on all of the following operating systems:
• Windows 8, Windows 7, Windows Vista, XP SP3/2003 SP3/Vista SP2/7/2008/8 or newer, x32 or x64 edition
• Mac OS X 10.5.8 (Leopard)/10.6.1 (Snow Leopard)/10.7 (Lion)/10.8 (Mountain Lion) or newer, x32 or x64 editions
• Fedora 15 or newer, Ubuntu 10.04, 11.04 or newer, x32 or x64 editions

This article refers to Able2Extract  and Able2Extract Professional.

 

Have more questions? Submit a request

Comments

Powered by Zendesk